The incident is now resolved. Users should no longer experience issues with the custom domain used for their editions (incorrect send-from email address/domain).
Posted May 28, 2024 - 17:49 EDT
Update
The incident is now resolved. Users should no longer experience issues with the custom domain used for their editions (incorrect send-from email address/domain).
Posted May 28, 2024 - 17:49 EDT
Monitoring
We have implemented a fix for the incident related to custom domains in Axios HQ and are monitoring the situation