Resolved
The issue has been resolved. We apologize for any inconvenience the disruption may have caused.
Monitoring
The Email Service Provider has deployed a fix that should resolve the issue. Sends should be fully functional at this time. We will continue to monitor to ensure that everything is running smoothly.
Investigating
We are seeing intermittent failed sends as our email provider, Mailgun, is experiencing degraded performance.