Degraded Performance - ESP
Resolved·Degraded performance

The issue has been resolved. We apologize for any inconvenience the disruption may have caused.

Wed, May 14, 2025, 10:44 PM
(3 weeks ago)
·
Affected components
Updates

Resolved

The issue has been resolved. We apologize for any inconvenience the disruption may have caused.

Wed, May 14, 2025, 10:44 PM

Identified

Our Email Service Provider, Mailgun, is experiencing degraded performance. This might lead to failed sends. If you believe your edition has not reached your audience, please contact help@axioshq.com

Wed, May 14, 2025, 09:33 PM(1 hour earlier)