Issue with our upstream provider
Resolved·Degraded performance

The issue has been resolved. We apologize for any inconvenience the disruption may have caused.

Tue, Oct 21, 2025, 12:53 AM
(4 days ago)
·
Affected components
Analytics
Updates

Resolved

The issue has been resolved. We apologize for any inconvenience the disruption may have caused.

Tue, Oct 21, 2025, 12:53 AM

Investigating

Our upstream provider, AWS, has been experiencing an incident since 3:00 AM EST, which affected multiple of our services. Functionality seems to be stabilizing, but feedback responses, polls and web editions are still experiencing errors. We will continue to monitor the situation and resolve the incident once AWS restores their service.

Mon, Oct 20, 2025, 02:20 PM(10 hours earlier)