Service Disruption: Sends, Uploads and Recipient Syncs
Resolved·Partial outage

The issue has been resolved. We apologize for any inconvenience the disruption may have caused.

Fri, Aug 29, 2025, 07:57 PM
(11 hours ago)
·
Affected components
Imports / Exports
Sending / Deliverability
WorkOS
Updates

Resolved

The issue has been resolved. We apologize for any inconvenience the disruption may have caused.

Fri, Aug 29, 2025, 07:57 PM

Investigating

We are seeing failed sends and service disruption as our infrastructure provider, AWS, is experiencing a service issue. We are currently working to identify the root cause of this issue. We apologize for any inconvenience

Fri, Aug 29, 2025, 07:13 PM(43 minutes earlier)